Adding GPO Pack support in MDT 2013 for Windows 8.1 & 2012 R2

If you ever tried to use GPO Packs in or ConfigMgr 01 R2, you quickly find out they will fail for Windows 8.1 or 2012 R2. The reason?  Microsoft forgot to add support for Windows 8.1 in the ZTIApplyGPOPack.wsf script.
Luckily it’s easy to fix, and while you’re at it, why not also add support for Windows Server 201 R2.

Fix the

Find the following section in ZTIApplyGPOPack.wsf (line 86 – 92):

sOSVersion = oEnvironment.Item(R0;OSCurrentVersion”)
If (Left(sOSVersion,3) = R0;6.2”) and oEnvironment.Item(“IsServerOS”) then
    sOS = R0;WS2012RTM”
    oLogging.CreateEntry R0;Using Default Windows Server 2012 RTM GPO Pack”, LogTypeInfo
ElseIf (Left(sOSVersion,3) = R0;6.2”) and Not(oEnvironment.Item(“IsServerOS”)) then
    sOS = R0;Win8RTM”
    oLogging.CreateEntry R0;Using Default Windows 8 RTM GPO Pack”, LogTypeInfoAnd change to:

If (Left(sOSVersion,3) = R0;6.3”) and oEnvironment.Item(“IsServerOS”) then
    sOS = R0;WS2012R2”
    oLogging.CreateEntry R0;Using Windows Server 2012 SP1 PO Pack”, LogTypeInfo
ElseIf (Left(sOSVersion,3) = R0;6.3”) and Not(oEnvironment.Item(“IsServerOS”)) then
    sOS = R0;Win81”
    oLogging.CreateEntry R0;Using Windows 8.1 GPO Pack”, LogTypeInfo
ElseIf (Left(sOSVersion,3) = R0;6.2”) and oEnvironment.Item(“IsServerOS”) then
    sOS = R0;WS2012RTM”
    oLogging.CreateEntry R0;Using Default Windows Server 2012 RTM GPO Pack”, LogTypeInfo
ElseIf (Left(sOSVersion,3) = “6.2”) and Not(oEnvironment.Item(“IsServerOS”)) then
    sOS = “Win8RTM”
    oLogging.CreateEntry “Using Default Windows 8 RTM GPO Pack”, LogTypeInfo

Or download the file Winking smile

ZTIApplyGPOPack.7z

Translate »
%d bloggers like this: