Windows Server Backup Applications Grijs VSS snapin Exchange 2007 SP2.

Ik had een probleem met Server Backup op een SP2 server met daarom SP2.

Onder Windows Server Backup was Applications grijs. Deze kon ik niet kiezen ook al had ik een goede backup voor zo ver ik wist.
 exchange 2007 sp2 issue

Nadat ik een vraag hierover gepost had op Exchange Forum kreeg ik een link naar naar het volgende artikel KB 958662. Het artikel van heb ik aangepast voor en beschreven hier onder.

Stap 1.
1. “Vssadmin list writers
 image

2. Kijk bij Microsoft Exchange Writer.

Sla het Writer Instance Id in notepad op van de Microsoft Exchange Writer
image

Stap 2.

Controleer of de  Exchange VSS writer is geregistreerd met Windows Server Backup, doe je de volgende stappen:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion

  3. Right-click CurrentVersion, point to New, and then click Key.
  4. Type WindowsServerBackup, and then press ENTER.
  5. Right-click WindowsServerBackup, point to New, and then click Key.
  6. Type Application Support, and then press ENTER.
  7. Right-click Application Support, point to New, and then click Key.
  8. Type {Writer Instance Id } and then press ENTER.
  9. Right-click {Writer Instance Id } point to New, and then click String Value.
  10. Type Application Identifier, and then press ENTER.
  11. Right-click Application Identifier, and then click Modify.
  12. In the Value data box, type Exchange, and then click OK.
  13. On the File menu, click Exit.

image

Stap 3.

Open de Exchange Best Practices Analyzer (exBPA) en controleer nadat je Health Scan hebt uitgevoerd of er geen vreemde fouten meer tegen komt.

Stap 4
Controleer ook even de locatie’s waar de mailbox/public folder database, log files & system files van de desbetreffende storage groepen hebt staan.

Zie de twee afbeeldingen hier onder.

image image

LET OP: Alle volumes waar deze mailbox en of public folder data is opgeslagen moet mee genomen worden in de backup. Anders blijft het vinkje bij Applications grijs.

Oplossing
Probleem was dat mijn mailbox data over meerdere volumes verspreid was geraakt door alle testen.
Tijdens Windows Server Backup had ik alleen het volume aangevinkt waar de mailbox database op stond. Data verplaatst en een nieuwe backup gemaakt  met daarin de juiste volumes aangevinkt en nu werkt het allemaal.

image

Leave a Reply